Technical Support Forum Index
Technical Support Forum
Access ChemAxon scientists and developers here. For registration and login issues contact website support.
Jchem Web Service "System cannot execute specified prog
To watch this topic for replies  Register (enables digests) or give email address:
Reply to topic
Display posts from previous:   
    View previous topic :: View next topic    
Author Message
wesm

Joined: 18 Sep 2008
Posts: 12

View user's profile

Back to top
Link to postPosted: Fri Oct 15, 2010 8:03 pmPost subject: Jchem Web Service "System cannot execute specified prog Reply with quote

When trying to install the Jchem Web Services Windows service, I get this error:

C:\Program Files\ChemAxon\JChem Web Services\bin>JChemWebServices.exe /Service
The system cannot execute the specified program.

I can run the service with the batch file directly, but this is a problem as it does not start automatically after the machine restarts for updates, etc.

System Details:

  • Jchem 5.3.4
  • Jchem Web Services 5.3.4
  • Windows Server 2003 SP2 32bit

Any suggestions?

ebuki
ChemAxon personnel
Joined: 03 Jan 2006
Posts: 349

View user's profile
Visit poster's website

Back to top
Link to postPosted: Mon Oct 18, 2010 5:27 pmPost subject: Reply with quote

Hi,

please check, if the logged on user has permission to run that file.
Also please send me a screenshot about the error message in the EventViewer.

Regards, Edvard

wesm

Joined: 18 Sep 2008
Posts: 12

View user's profile

Back to top
Link to postPosted: Mon Oct 18, 2010 6:13 pmPost subject: Reply with quote

Hi Edvard, the user does have premissions.  I'm running as Administrator to set up the service.  The event log has more enlightening details though.  Log messages come in a group of three when I run JchemWebServices.exe:



Event Type:    Error
Event Source:    SideBySide
Event Category:    None
Event ID:    32
Date:        10/18/2010
Time:        12:00:31 PM
User:        N/A
Computer:    SERVER
Description:
Dependent Assembly Microsoft.VC90.CRT could not be found and Last Error was The referenced assembly is not installed on your system.

Event Type:    Error
Event Source:    SideBySide
Event Category:    None
Event ID:    59
Date:        10/18/2010
Time:        12:00:31 PM
User:        N/A
Computer:    SERVER
Description:
Resolve Partial Assembly failed for Microsoft.VC90.CRT. Reference error message: The referenced assembly is not installed on your system.

Event Type:    Error
Event Source:    SideBySide
Event Category:    None
Event ID:    59
Date:        10/18/2010
Time:        12:00:31 PM
User:        N/A
Computer:    SERVER
Description:
Generate Activation Context failed for C:\Program Files\ChemAxon\JChem Web Services\bin\JChemWebServices.exe. Reference error message: The referenced assembly is not installed on your system.


So it looks like I'm missing some library dependency that wasn't installed with the Web Services package.  Shouldn't the installer have taken care of dependencies?

ebuki
ChemAxon personnel
Joined: 03 Jan 2006
Posts: 349

View user's profile
Visit poster's website

Back to top
Link to postPosted: Wed Oct 20, 2010 12:14 pmPost subject: Reply with quote

Hi,

It seems to be something is wrong at your side, JChemWebServices.exe uses just standard ATL libraries.
I attached a new instance of that file, please try to run a test with that. If the error has not been fixed you should try to update your system.

Edvard




 Filename: JChemWebServices.zip    Filesize: 47.01 KB    Downloaded: 18 Time(s)
 Description:  unzip the file
wesm

Joined: 18 Sep 2008
Posts: 12

View user's profile

Back to top
Link to postPosted: Wed Oct 20, 2010 6:50 pmPost subject: Reply with quote

That replacement file works! Thanks!

Curiously, the original executable from the install is only 37 KB, while the replacement you gave me is 92 KB.  Could the bad one have been compiled without some necessary headers?

ebuki
ChemAxon personnel
Joined: 03 Jan 2006
Posts: 349

View user's profile
Visit poster's website

Back to top
Link to postPosted: Thu Oct 21, 2010 3:42 pmPost subject: Reply with quote

Hi,

We changed the CRT module and rebuilt the application with this.

Regards, Edvard

Reply to topic
Page 1 of 1


To watch this topic for replies   Register (enables digests) or give email address  
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You can download files in this forum